Back to overview
Downtime

Dashboard under maintenance

Mar 10, 2025 at 2:25pm UTC
Affected services
Dashboard

Resolved
Mar 10, 2025 at 4:03pm UTC

All up and running now

Updated
Mar 10, 2025 at 3:23pm UTC

The dashboard is accessible again, but still limited in some features

Created
Mar 10, 2025 at 2:25pm UTC

The dashboard is currently undergoing maintenance, and should be available shortly.