Back to overview
Downtime

Dashboard is unavailable

Jun 24, 2024 at 08:22am UTC
Affected services
Dashboard

Resolved
Jun 24, 2024 at 08:35am UTC

The incident is resolved

Created
Jun 24, 2024 at 08:22am UTC

Our server provider is currently experiencing an outage affecting our dashboard. As a result, the dashboard is temporarily unavailable.