Back to overview
Degraded

Mail sending delay

Dec 11 at 04:42pm CET
Affected services
Dashboard

Resolved
Dec 11 at 07:44pm CET

E-mails are working properly

Created
Dec 11 at 04:42pm CET

There was a delay in sending emails in the dashboard. This is being resolved by our supplier.

Check here for more informations : https://status.mailjet.com/incidents/rwgz0pmnshv8