Back to overview
Degraded

Emails experiencing delays in their delivery

Jun 22 at 05:45pm CEST
Affected services
Dashboard

Resolved
Jun 22 at 08:54pm CEST

Emails are working again

Created
Jun 22 at 05:45pm CEST

Our e-mail provider is currently experiencing a outage with their server, which is causing a delays in their emails delivery.

Impacted services :
- new subscriptions
- password changes
- quota alerts

The incident can be tracked via this link: https://status.mailjet.com/